What’s Vulnerable › Vulnerabilities
CVE-2018-19576
- Severity: high (CVSS 8.1 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2019-07-10 · updated 2026-06-17
- Weakness: CWE-284
Description
GitLab CE/EE, versions 8.6 up to 11.x before 11.3.11, 11.4 before 11.4.8, and 11.5 before 11.5.1, are vulnerable to an access control issue that allows a Guest user to make changes to or delete their own comments on an issue, after the issue was made Confidential.
Affected products
- GitLab: from 8.6.0 before 11.3.11; from 11.4.0 before 11.4.8; from 11.5.0 before 11.5.1 — fixed in 11.3.11, 11.4.8, 11.5.1
How to fix
Upgrade to a fixed version: GitLab 11.3.11, 11.4.8, 11.5.1. Check the vendor advisory for mitigations.
References
- https://about.gitlab.com/2018/11/28/security-release-gitlab-11-dot-5-dot-1-released/
- https://gitlab.com/gitlab-org/gitlab-ce/issues/51238
- https://about.gitlab.com/2018/11/28/security-release-gitlab-11-dot-5-dot-1-released/
- https://gitlab.com/gitlab-org/gitlab-ce/issues/51238
Get alerted when CVE-2018-19576 or the next vulnerability affects your stack