What’s Vulnerable › Vulnerabilities
CVE-2018-19579
- Severity: medium (CVSS 5.4 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2019-07-10 · updated 2026-06-17
- Weakness: CWE-79
Description
GitLab EE version 11.5 is vulnerable to a persistent XSS vulnerability in the Operations page. This is fixed in 11.5.1.
Affected products
- GitLab: from 11.5.0 before 11.5.1 — fixed in 11.5.1
How to fix
Upgrade to a fixed version: GitLab 11.5.1. Check the vendor advisory for mitigations.
References
- https://about.gitlab.com/2018/11/28/security-release-gitlab-11-dot-5-dot-1-released/
- https://gitlab.com/gitlab-org/gitlab-ce/issues/53917
- https://about.gitlab.com/2018/11/28/security-release-gitlab-11-dot-5-dot-1-released/
- https://gitlab.com/gitlab-org/gitlab-ce/issues/53917
Get alerted when CVE-2018-19579 or the next vulnerability affects your stack