What’s Vulnerable › Vulnerabilities
CVE-2018-19581
- Severity: high (CVSS 7.5 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2019-07-10 · updated 2026-06-17
- Weakness: CWE-285
Description
GitLab EE, versions 8.3 up to 11.x before 11.3.11, 11.4 before 11.4.8, and 11.5 before 11.5.1, is vulnerable to an insecure object reference vulnerability that allows a Guest user to set the weight of an issue they create.
Affected products
- GitLab: from 8.3.0 before 11.3.11; from 11.4.0 before 11.4.8; from 11.5.0 before 11.5.1 — fixed in 11.3.11, 11.4.8, 11.5.1
How to fix
Upgrade to a fixed version: GitLab 11.3.11, 11.4.8, 11.5.1. Check the vendor advisory for mitigations.
References
- https://about.gitlab.com/2018/11/28/security-release-gitlab-11-dot-5-dot-1-released/
- https://gitlab.com/gitlab-org/gitlab-ee/issues/7696
- https://about.gitlab.com/2018/11/28/security-release-gitlab-11-dot-5-dot-1-released/
- https://gitlab.com/gitlab-org/gitlab-ee/issues/7696
Get alerted when CVE-2018-19581 or the next vulnerability affects your stack