What’s Vulnerable › Vulnerabilities

CVE-2018-19608

Description

Arm Mbed TLS before 2.14.1, before 2.7.8, and before 2.1.17 allows a local unprivileged attacker to recover the plaintext of RSA decryption, which is used in RSA-without-(EC)DH(E) cipher suites.

Affected products

How to fix

Upgrade to a fixed version: mbedtls 2.1.17, 2.7.8; TrustedFirmware Mbed TLS 2.14.1. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2018-19608 or the next vulnerability affects your stack