What’s Vulnerable › Vulnerabilities
CVE-2018-19636: Local root exploit via inclusion of attacker controlled shell script
- Severity: high (CVSS 7.8 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2019-03-05 · updated 2026-06-17
- Weakness: CWE-306
Description
Supportutils, before version 3.1-5.7.1, when run with command line argument -A searched the file system for a ndspath binary. If an attacker provides one at an arbitrary location it is executed with root privileges
Affected products
- SUSE supportutils: before 3.1-5.7.1 — fixed in 3.1-5.7.1
How to fix
Upgrade to a fixed version: SUSE supportutils 3.1-5.7.1. Check the vendor advisory for mitigations.
References
- http://lists.opensuse.org/opensuse-security-announce/2019-05/msg00018.html
- https://bugzilla.suse.com/show_bug.cgi?id=1117751
- http://lists.opensuse.org/opensuse-security-announce/2019-05/msg00018.html
- https://bugzilla.suse.com/show_bug.cgi?id=1117751
Get alerted when CVE-2018-19636 or the next vulnerability affects your stack