What’s Vulnerable › Vulnerabilities
CVE-2018-19639: Code execution if run with command line switch -v
- Severity: high (CVSS 7.8 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2019-03-05 · updated 2026-06-17
- Weakness: CWE-78
Description
If supportutils before version 3.1-5.7.1 is run with -v to perform rpm verification and the attacker manages to manipulate the rpm listing (e.g. with CVE-2018-19638) he can execute arbitrary commands as root.
Affected products
- SUSE supportutils: before 3.1-5.7.1 — fixed in 3.1-5.7.1
How to fix
Upgrade to a fixed version: SUSE supportutils 3.1-5.7.1. Check the vendor advisory for mitigations.
References
- http://lists.opensuse.org/opensuse-security-announce/2019-05/msg00018.html
- https://bugzilla.suse.com/show_bug.cgi?id=1118462
- http://lists.opensuse.org/opensuse-security-announce/2019-05/msg00018.html
- https://bugzilla.suse.com/show_bug.cgi?id=1118462
Get alerted when CVE-2018-19639 or the next vulnerability affects your stack