What’s Vulnerable › Vulnerabilities
CVE-2018-19640: Code execution if run with command line switch -v
- Severity: medium (CVSS 5.5 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2019-03-05 · updated 2026-06-17
- Weakness: CWE-377
Description
If the attacker manages to create files in the directory used to collect log files in supportutils before version 3.1-5.7.1 (e.g. with CVE-2018-19638) he can kill arbitrary processes on the local machine.
Affected products
- SUSE supportutils: before 3.1-5.7.1 — fixed in 3.1-5.7.1
How to fix
Upgrade to a fixed version: SUSE supportutils 3.1-5.7.1. Check the vendor advisory for mitigations.
References
- http://lists.opensuse.org/opensuse-security-announce/2019-05/msg00018.html
- https://bugzilla.suse.com/show_bug.cgi?id=1118463
- http://lists.opensuse.org/opensuse-security-announce/2019-05/msg00018.html
- https://bugzilla.suse.com/show_bug.cgi?id=1118463
Get alerted when CVE-2018-19640 or the next vulnerability affects your stack