What’s Vulnerable › Vulnerabilities
CVE-2018-19837
- Severity: medium (CVSS 6.5 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.8% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2018-12-04 · updated 2026-06-17
- Weakness: CWE-400
Description
In LibSass prior to 3.5.5, Sass::Eval::operator()(Sass::Binary_Expression*) inside eval.cpp allows attackers to cause a denial-of-service resulting from stack consumption via a crafted sass file, because of certain incorrect parsing of '%' as a modulo operator in parser.cpp.
Affected products
- Sass-Lang Libsass: before 3.5.5 — fixed in 3.5.5
How to fix
Upgrade to a fixed version: Sass-Lang Libsass 3.5.5. Check the vendor advisory for mitigations.
References
- http://lists.opensuse.org/opensuse-security-announce/2019-07/msg00047.html
- http://lists.opensuse.org/opensuse-security-announce/2019-07/msg00051.html
- http://lists.opensuse.org/opensuse-security-announce/2019-08/msg00027.html
- https://github.com/sass/libsass/commit/210fdff7a65370c2ae24e022a2b35da8c423cc5f
- https://github.com/sass/libsass/issues/2659
- http://lists.opensuse.org/opensuse-security-announce/2019-07/msg00047.html
- http://lists.opensuse.org/opensuse-security-announce/2019-07/msg00051.html
- http://lists.opensuse.org/opensuse-security-announce/2019-08/msg00027.html
- https://github.com/sass/libsass/commit/210fdff7a65370c2ae24e022a2b35da8c423cc5f
- https://github.com/sass/libsass/issues/2659
Get alerted when CVE-2018-19837 or the next vulnerability affects your stack