What’s Vulnerable › Vulnerabilities
CVE-2018-19854
- Severity: medium (CVSS 4.7 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2018-12-04 · updated 2026-06-17
- Weakness: CWE-200
Description
An issue was discovered in the Linux kernel before 4.19.3. crypto_report_one() and related functions in crypto/crypto_user.c (the crypto user configuration API) do not fully initialize structures that are copied to userspace, potentially leaking sensitive memory to user programs. NOTE: this is a CVE-2013-2547 regression but with easier exploitability because the attacker does not need a capability (however, the system must have the CONFIG_CRYPTO_USER kconfig option).
Affected products
- Canonical Ubuntu Linux: 14.04, 16.04, 18.04, 18.10
- Linux kernel: before 4.19.3 — fixed in 4.19.3
How to fix
Upgrade to a fixed version: Linux kernel 4.19.3. Check the vendor advisory for mitigations.
References
- http://git.kernel.org/cgit/linux/kernel/git/torvalds/linux.git/commit/?id=f43f39958beb206b53292801e216d9b8a660f087
- https://access.redhat.com/errata/RHSA-2019:3309
- https://access.redhat.com/errata/RHSA-2019:3517
- https://github.com/torvalds/linux/commit/f43f39958beb206b53292801e216d9b8a660f087
- https://kernel.org/pub/linux/kernel/v4.x/ChangeLog-4.19.3
- https://usn.ubuntu.com/3872-1/
- https://usn.ubuntu.com/3878-1/
- https://usn.ubuntu.com/3878-2/
- https://usn.ubuntu.com/3901-1/
- https://usn.ubuntu.com/3901-2/
- http://git.kernel.org/cgit/linux/kernel/git/torvalds/linux.git/commit/?id=f43f39958beb206b53292801e216d9b8a660f087
- https://access.redhat.com/errata/RHSA-2019:3309
Get alerted when CVE-2018-19854 or the next vulnerability affects your stack