What’s Vulnerable › Vulnerabilities
CVE-2018-19869
- Severity: medium (CVSS 6.5 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2018-12-26 · updated 2026-06-17
- Weakness: CWE-20
Description
An issue was discovered in Qt before 5.11.3. A malformed SVG image causes a segmentation fault in qsvghandler.cpp.
Affected products
- openSUSE Leap: 15.0
- Qt: before 5.11.3 — fixed in 5.11.3
How to fix
Upgrade to a fixed version: Qt 5.11.3. Check the vendor advisory for mitigations.
References
- http://lists.opensuse.org/opensuse-security-announce/2019-04/msg00008.html
- http://lists.opensuse.org/opensuse-security-announce/2020-09/msg00057.html
- http://lists.opensuse.org/opensuse-security-announce/2020-09/msg00071.html
- http://lists.opensuse.org/opensuse-security-announce/2020-09/msg00073.html
- http://lists.opensuse.org/opensuse-security-announce/2020-09/msg00090.html
- https://access.redhat.com/errata/RHSA-2019:2135
- https://blog.qt.io/blog/2018/12/04/qt-5-11-3-released-important-security-updates/
- https://codereview.qt-project.org/#/c/234142/
- https://lists.debian.org/debian-lts-announce/2019/05/msg00014.html
- https://lists.debian.org/debian-lts-announce/2020/09/msg00023.html
- https://lists.debian.org/debian-lts-announce/2020/10/msg00035.html
- http://lists.opensuse.org/opensuse-security-announce/2019-04/msg00008.html
Get alerted when CVE-2018-19869 or the next vulnerability affects your stack