What’s Vulnerable › Vulnerabilities
CVE-2018-19873
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 3.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2018-12-26 · updated 2026-06-17
- Weakness: CWE-119
Description
An issue was discovered in Qt before 5.11.3. QBmpHandler has a buffer overflow via BMP data.
Affected products
- Canonical Ubuntu Linux: 16.04, 18.04, 18.10
- Debian Linux: 8.0, 9.0
- openSUSE Backports: sle-15-sp1, sle-15-sp2
- openSUSE Leap: 15.1, 15.2, 42.3
- Qt: through 5.5.1; from 5.7.0 through 5.8.0; from 5.10.0 before 5.11.3 — fixed in 5.11.3
How to fix
Upgrade to a fixed version: Qt 5.11.3. Check the vendor advisory for mitigations.
References
- http://lists.opensuse.org/opensuse-security-announce/2018-12/msg00066.html
- http://lists.opensuse.org/opensuse-security-announce/2020-09/msg00057.html
- http://lists.opensuse.org/opensuse-security-announce/2020-09/msg00071.html
- http://lists.opensuse.org/opensuse-security-announce/2020-09/msg00073.html
- http://lists.opensuse.org/opensuse-security-announce/2020-09/msg00090.html
- https://access.redhat.com/errata/RHSA-2019:2135
- https://access.redhat.com/errata/RHSA-2019:3390
- https://blog.qt.io/blog/2018/12/04/qt-5-11-3-released-important-security-updates/
- https://codereview.qt-project.org/#/c/238749/
- https://lists.debian.org/debian-lts-announce/2019/01/msg00004.html
- https://lists.debian.org/debian-lts-announce/2019/05/msg00014.html
- https://lists.debian.org/debian-lts-announce/2020/09/msg00023.html
Get alerted when CVE-2018-19873 or the next vulnerability affects your stack