What’s Vulnerable › Vulnerabilities
CVE-2018-19908
- Severity: high (CVSS 8.8 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 17.3% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2018-12-06 · updated 2026-06-22
- Weakness: CWE-78
Description
An issue was discovered in MISP 2.4.9x before 2.4.99. In app/Model/Event.php (the STIX 1 import code), an unescaped filename string is used to construct a shell command. This vulnerability can be abused by a malicious authenticated user to execute arbitrary commands by tweaking the original filename of the STIX import.
Affected products
- MISP: from 2.4.90 before 2.4.99 — fixed in 2.4.99
How to fix
Upgrade to a fixed version: MISP 2.4.99. Check the vendor advisory for mitigations.
References
- https://github.com/MISP/MISP/commit/211ac0737281b65e7da160f0aac52f401a94e1a3
- https://github.com/MISP/MISP/releases/tag/v2.4.99
- https://www.exploit-db.com/exploits/46401/
- https://github.com/MISP/MISP/commit/211ac0737281b65e7da160f0aac52f401a94e1a3
- https://github.com/MISP/MISP/releases/tag/v2.4.99
- https://www.exploit-db.com/exploits/46401/
Get alerted when CVE-2018-19908 or the next vulnerability affects your stack