What’s Vulnerable › Vulnerabilities
CVE-2018-19935
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 6.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2018-12-07 · updated 2026-06-17
- Weakness: CWE-476
Description
ext/imap/php_imap.c in PHP 5.x and 7.x before 7.3.0 allows remote attackers to cause a denial of service (NULL pointer dereference and application crash) via an empty string in the message argument to the imap_mail function.
Affected products
- Debian Linux: 8.0, 9.0
- PHP: from 5.6.0 before 5.6.39; from 7.0.0 before 7.0.33; from 7.1.0 before 7.1.26; from 7.2.0 before 7.2.14 — fixed in 5.6.39, 7.0.33, 7.1.26, 7.2.14
How to fix
Upgrade to a fixed version: PHP 5.6.39, 7.0.33, 7.1.26, 7.2.14. Check the vendor advisory for mitigations.
References
- http://lists.opensuse.org/opensuse-security-announce/2019-06/msg00041.html
- http://lists.opensuse.org/opensuse-security-announce/2019-06/msg00044.html
- http://www.securityfocus.com/bid/106143
- https://bugs.php.net/bug.php?id=77020
- https://lists.debian.org/debian-lts-announce/2018/12/msg00006.html
- https://security.netapp.com/advisory/ntap-20181221-0003/
- https://www.debian.org/security/2018/dsa-4353
- http://lists.opensuse.org/opensuse-security-announce/2019-06/msg00041.html
- http://lists.opensuse.org/opensuse-security-announce/2019-06/msg00044.html
- http://www.securityfocus.com/bid/106143
- https://bugs.php.net/bug.php?id=77020
- https://lists.debian.org/debian-lts-announce/2018/12/msg00006.html
Get alerted when CVE-2018-19935 or the next vulnerability affects your stack