What’s Vulnerable › Vulnerabilities
CVE-2018-19942: Cross-site Scripting Vulnerability in File Station
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-04-16 · updated 2026-06-17
- Weakness: CWE-79
Description
A cross-site scripting (XSS) vulnerability has been reported to affect earlier versions of File Station. If exploited, this vulnerability allows remote attackers to inject malicious code. We have already fixed this vulnerability in the following versions: QTS 4.5.2.1566 build 20210202 (and later) QTS 4.5.1.1456 build 20201015 (and later) QTS 4.3.6.1446 build 20200929 (and later) QTS 4.3.4.1463 build 20201006 (and later) QTS 4.3.3.1432 build 20201006 (and later) QTS 4.2.6 build 20210327 (and later) QuTS hero h4.5.1.1472 build 20201031 (and later) QuTScloud c4.5.4.1601 build 20210309 (and later) QuTScloud c4.5.3.1454 build 20201013 (and later)
Affected products
- QNAP QTS: before 4.2.6; from 4.3.5 before 4.3.6; from 4.4.0 before 4.5.1; 4.2.6, 4.2.6-build_20170517, 4.2.6-build_20190322, 4.2.6-build_20190730, 4.2.6-build_20190921, 4.2.6-build_20191107 (+92) — fixed in 4.2.6, 4.3.6, 4.5.1
- QNAP Systems Inc. QuTS hero: before h4.5.1; h4.5.1 — fixed in h4.5.1
- QNAP Systems Inc. QuTScloud: before c4.5.3; c4.5.3, c4.5.4 — fixed in c4.5.3
How to fix
Upgrade to a fixed version: QNAP QTS 4.2.6, 4.3.6, 4.5.1; QNAP Systems Inc. QuTS hero h4.5.1; QNAP Systems Inc. QuTScloud c4.5.3. Check the vendor advisory for mitigations.
References
- https://www.qnap.com/zh-tw/security-advisory/qsa-21-04
- https://www.qnap.com/zh-tw/security-advisory/qsa-21-04
Get alerted when CVE-2018-19942 or the next vulnerability affects your stack