What’s Vulnerable › Vulnerabilities
CVE-2018-19943: QNAP NAS File Station Cross-Site Scripting Vulnerability
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: yes — in CISA KEV since 2022-05-24
- EPSS: 22.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2020-10-28 · updated 2026-08-13
- Weakness: CWE-79
Description
If exploited, this cross-site scripting vulnerability could allow remote attackers to inject malicious code. QNAP has already fixed these issues in the following QTS versions. QTS 4.4.2.1270 build 20200410 and later QTS 4.4.1.1261 build 20200330 and later QTS 4.3.6.1263 build 20200330 and later QTS 4.3.4.1282 build 20200408 and later QTS 4.3.3.1252 build 20200409 and later QTS 4.2.6 build 20200421 and later
Affected products
- QNAP QTS: before 4.2.6; from 4.3.1.0013 before 4.3.3.1252; from 4.3.4 before 4.3.4.1282; from 4.3.6 before 4.3.6.1263; from 4.4.0 before 4.4.1.1261; from 4.4.2 before 4.4.2.1270 — fixed in 4.2.6, 4.3.3.1252, 4.3.4.1282, 4.3.6.1263, 4.4.1.1261, 4.4.2.1270
How to fix
Upgrade to a fixed version: QNAP QTS 4.2.6, 4.3.3.1252, 4.3.4.1282, 4.3.6.1263. Check the vendor advisory for mitigations.
References
- https://www.qnap.com/zh-tw/security-advisory/qsa-20-01
- https://www.qnap.com/zh-tw/security-advisory/qsa-20-01
- https://www.cisa.gov/known-exploited-vulnerabilities-catalog?field_cve=CVE-2018-19943
Get alerted when CVE-2018-19943 or the next vulnerability affects your stack