What’s Vulnerable › Vulnerabilities
CVE-2018-19946
- Severity: medium (CVSS 5.9 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2020-09-11 · updated 2026-06-17
- Weakness: CWE-295
Description
The vulnerability have been reported to affect earlier versions of Helpdesk. If exploited, this improper certificate validation vulnerability could allow an attacker to spoof a trusted entity by interfering in the communication path between the host and client. QNAP has already fixed the issue in Helpdesk 3.0.3 and later.
Affected products
- QNAP Systems Inc. Helpdesk: before 3.0.3 — fixed in 3.0.3
How to fix
Upgrade to a fixed version: QNAP Systems Inc. Helpdesk 3.0.3. Check the vendor advisory for mitigations.
References
- https://www.qnap.com/zh-tw/security-advisory/qsa-20-05
- https://www.qnap.com/zh-tw/security-advisory/qsa-20-05
Get alerted when CVE-2018-19946 or the next vulnerability affects your stack