What’s Vulnerable › Vulnerabilities
CVE-2018-19950
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2020-11-02 · updated 2026-06-17
- Weakness: CWE-77
Description
If exploited, this command injection vulnerability could allow remote attackers to execute arbitrary commands. This issue affects: QNAP Systems Inc. Music Station versions prior to 5.1.13; versions prior to 5.2.9; versions prior to 5.3.11.
Affected products
- QNAP Systems Inc. Music Station: from 5.3.0 before 5.3.11; before 5.1.13; from 5.2.0 before 5.2.9 — fixed in 5.1.13, 5.2.9, 5.3.11
How to fix
Upgrade to a fixed version: QNAP Systems Inc. Music Station 5.1.13, 5.2.9, 5.3.11. Check the vendor advisory for mitigations.
References
- https://www.qnap.com/en/security-advisory/qsa-20-10
- https://www.qnap.com/en/security-advisory/qsa-20-10
Get alerted when CVE-2018-19950 or the next vulnerability affects your stack