What’s Vulnerable › Vulnerabilities
CVE-2018-19954
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.9% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2020-11-02 · updated 2026-06-17
- Weakness: CWE-79
Description
The cross-site scripting vulnerability has been reported to affect earlier versions of Photo Station. If exploited, the vulnerability could allow remote attackers to inject malicious code. This issue affects: QNAP Systems Inc. Photo Station versions prior to 5.7.11; versions prior to 6.0.10.
Affected products
- QNAP Systems Inc. Photo Station: from 5.7.0 before 5.7.11; from 6.0.0 before 6.0.10 — fixed in 5.7.11, 6.0.10
How to fix
Upgrade to a fixed version: QNAP Systems Inc. Photo Station 5.7.11, 6.0.10. Check the vendor advisory for mitigations.
References
- https://www.qnap.com/en/security-advisory/qsa-20-11
- https://www.qnap.com/en/security-advisory/qsa-20-11
Get alerted when CVE-2018-19954 or the next vulnerability affects your stack