What’s Vulnerable › Vulnerabilities
CVE-2018-19957: Insufficient HTTP Security Headers in QTS, QuTS hero, and QuTScloud
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-09-10 · updated 2026-06-17
- Weakness: CWE-1021
Description
A vulnerability involving insufficient HTTP security headers has been reported to affect QNAP NAS running QTS, QuTS hero, and QuTScloud. This vulnerability allows remote attackers to launch privacy and security attacks. We have already fixed this vulnerability in the following versions: QTS 4.5.4.1715 build 20210630 and later QuTS hero h4.5.4.1771 build 20210825 and later QuTScloud c4.5.6.1755 build 20210809 and later
Affected products
- QNAP QTS: before 4.5.4.1715 — fixed in 4.5.4.1715
- QNAP Systems Inc. QuTS hero: before h4.5.4.1771 — fixed in h4.5.4.1771
- QNAP Systems Inc. QuTScloud: before c4.5.6.1755 — fixed in c4.5.6.1755
How to fix
Upgrade to a fixed version: QNAP QTS 4.5.4.1715; QNAP Systems Inc. QuTS hero h4.5.4.1771; QNAP Systems Inc. QuTScloud c4.5.6.1755. Check the vendor advisory for mitigations.
References
- https://www.qnap.com/en/security-advisory/qsa-21-03
- https://www.qnap.com/en/security-advisory/qsa-21-03
Get alerted when CVE-2018-19957 or the next vulnerability affects your stack