What’s Vulnerable › Vulnerabilities
CVE-2018-19968
- Severity: medium (CVSS 6.5 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.9% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2018-12-11 · updated 2026-06-17
- Weakness: CWE-200
Description
An attacker can exploit phpMyAdmin before 4.8.4 to leak the contents of a local file because of an error in the transformation feature. The attacker must have access to the phpMyAdmin Configuration Storage tables, although these can easily be created in any database to which the attacker has access. An attacker must have valid credentials to log in to phpMyAdmin; this vulnerability does not allow an attacker to circumvent the login system.
Affected products
- Debian Linux: 8.0
- phpMyAdmin: from 4.0.0 before 4.8.4 — fixed in 4.8.4
How to fix
Upgrade to a fixed version: phpMyAdmin 4.8.4. Check the vendor advisory for mitigations.
References
- http://www.securityfocus.com/bid/106178
- https://lists.debian.org/debian-lts-announce/2019/02/msg00003.html
- https://security.gentoo.org/glsa/201904-16
- https://www.phpmyadmin.net/security/PMASA-2018-6/
- http://www.securityfocus.com/bid/106178
- https://lists.debian.org/debian-lts-announce/2019/02/msg00003.html
- https://security.gentoo.org/glsa/201904-16
- https://www.phpmyadmin.net/security/PMASA-2018-6/
Get alerted when CVE-2018-19968 or the next vulnerability affects your stack