What’s Vulnerable › Vulnerabilities
CVE-2018-19969
- Severity: high (CVSS 8.8 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2018-12-11 · updated 2026-06-17
- Weakness: CWE-352
Description
phpMyAdmin 4.7.x and 4.8.x versions prior to 4.8.4 are affected by a series of CSRF flaws. By deceiving a user into clicking on a crafted URL, it is possible to perform harmful SQL operations such as renaming databases, creating new tables/routines, deleting designer pages, adding/deleting users, updating user passwords, killing SQL processes, etc.
Affected products
- phpMyAdmin: from 4.7.0 through 4.7.6; from 4.8.0 before 4.8.4 — fixed in 4.8.4
How to fix
Upgrade to a fixed version: phpMyAdmin 4.8.4. Check the vendor advisory for mitigations.
References
- http://www.securityfocus.com/bid/106175
- https://security.gentoo.org/glsa/201904-16
- https://www.phpmyadmin.net/security/PMASA-2018-7/
- http://www.securityfocus.com/bid/106175
- https://security.gentoo.org/glsa/201904-16
- https://www.phpmyadmin.net/security/PMASA-2018-7/
Get alerted when CVE-2018-19969 or the next vulnerability affects your stack