What’s Vulnerable › Vulnerabilities
CVE-2018-1999010
- Severity: critical (CVSS 9.8 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 3.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2018-07-23 · updated 2026-06-17
- Weakness: CWE-125
Description
FFmpeg before commit cced03dd667a5df6df8fd40d8de0bff477ee02e8 contains multiple out of array access vulnerabilities in the mms protocol that can result in attackers accessing out of bound data. This attack appear to be exploitable via network connectivity. This vulnerability appears to have been fixed in cced03dd667a5df6df8fd40d8de0bff477ee02e8 and later.
Affected products
- Debian Linux: 8.0
- FFmpeg: before 3.4.3 — fixed in 3.4.3
How to fix
Upgrade to a fixed version: FFmpeg 3.4.3. Check the vendor advisory for mitigations.
References
- http://www.securityfocus.com/bid/104896
- https://github.com/FFmpeg/FFmpeg/commit/cced03dd667a5df6df8fd40d8de0bff477ee02e8
- https://lists.debian.org/debian-lts-announce/2019/01/msg00006.html
- http://www.securityfocus.com/bid/104896
- https://github.com/FFmpeg/FFmpeg/commit/cced03dd667a5df6df8fd40d8de0bff477ee02e8
- https://lists.debian.org/debian-lts-announce/2019/01/msg00006.html
Get alerted when CVE-2018-1999010 or the next vulnerability affects your stack