What’s Vulnerable › Vulnerabilities
CVE-2018-1999024
- Severity: medium (CVSS 5.4 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.4% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2018-07-23 · updated 2026-06-17
- Weakness: CWE-79
Description
MathJax version prior to version 2.7.4 contains a Cross Site Scripting (XSS) vulnerability in the \unicode{} macro that can result in Potentially untrusted Javascript running within a web browser. This attack appear to be exploitable via The victim must view a page where untrusted content is processed using Mathjax. This vulnerability appears to have been fixed in 2.7.4 and later.
Affected products
- Mathjax: before 2.7.4 — fixed in 2.7.4
How to fix
Upgrade to a fixed version: Mathjax 2.7.4. Check the vendor advisory for mitigations.
References
- https://blog.bentkowski.info/2018/06/xss-in-google-colaboratory-csp-bypass.html
- https://github.com/mathjax/MathJax/commit/a55da396c18cafb767a26aa9ad96f6f4199852f1
- https://blog.bentkowski.info/2018/06/xss-in-google-colaboratory-csp-bypass.html
- https://github.com/mathjax/MathJax/commit/a55da396c18cafb767a26aa9ad96f6f4199852f1
Get alerted when CVE-2018-1999024 or the next vulnerability affects your stack