What’s Vulnerable › Vulnerabilities
CVE-2018-20020
- Severity: critical (CVSS 9.8 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 8.8% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2018-12-19 · updated 2026-06-17
- Weakness: CWE-787
Description
LibVNC before commit 7b1ef0ffc4815cab9a96c7278394152bdc89dc4d contains heap out-of-bound write vulnerability inside structure in VNC client code that can result remote code execution
Affected products
- Canonical Ubuntu Linux: 14.04, 16.04, 18.04, 18.10
- Debian Linux: 8.0, 9.0
- Libvnc Project Libvncserver: before 0.9.12 — fixed in 0.9.12
How to fix
Upgrade to a fixed version: Libvnc Project Libvncserver 0.9.12. Check the vendor advisory for mitigations.
References
- https://ics-cert.kaspersky.com/advisories/klcert-advisories/2018/12/19/klcert-18-030-libvnc-heap-out-of-bound-write/
- https://lists.debian.org/debian-lts-announce/2018/12/msg00017.html
- https://lists.debian.org/debian-lts-announce/2019/10/msg00042.html
- https://lists.debian.org/debian-lts-announce/2019/11/msg00033.html
- https://security.gentoo.org/glsa/201908-05
- https://security.gentoo.org/glsa/202006-06
- https://usn.ubuntu.com/3877-1/
- https://usn.ubuntu.com/4547-1/
- https://usn.ubuntu.com/4547-2/
- https://usn.ubuntu.com/4587-1/
- https://www.debian.org/security/2019/dsa-4383
- https://ics-cert.kaspersky.com/advisories/klcert-advisories/2018/12/19/klcert-18-030-libvnc-heap-out-of-bound-write/
Get alerted when CVE-2018-20020 or the next vulnerability affects your stack