What’s Vulnerable › Vulnerabilities
CVE-2018-20026
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 3.0% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2019-02-19 · updated 2026-06-17
Description
Improper Communication Address Filtering exists in CODESYS V3 products versions prior V3.5.14.0.
Affected products
- CODESYS Control for BeagleBone SL: from 3.0 before 3.5.14.0 — fixed in 3.5.14.0
- CODESYS Control For Empc-A/Imx6 Sl: from 3.0 before 3.5.14.0 — fixed in 3.5.14.0
- CODESYS Control for IOT2000 SL: from 3.0 before 3.5.14.0 — fixed in 3.5.14.0
- CODESYS Control for Linux SL: from 3.0 before 3.5.14.0 — fixed in 3.5.14.0
- CODESYS Control for PFC100 SL: from 3.0 before 3.5.14.0 — fixed in 3.5.14.0
- CODESYS Control for PFC200 SL: from 3.0 before 3.5.14.0 — fixed in 3.5.14.0
- CODESYS Control for Raspberry Pi SL: from 3.0 before 3.5.14.0 — fixed in 3.5.14.0
- CODESYS Control RTE (SL): from 3.0 before 3.5.14.0 — fixed in 3.5.14.0
- CODESYS Control Rte Sl (For Beckhoff Cx): from 3.0 before 3.5.14.0 — fixed in 3.5.14.0
- CODESYS Control Runtime Toolkit: from 3.0 before 3.5.14.0 — fixed in 3.5.14.0
- CODESYS Control Win (SL): from 3.0 before 3.5.14.0 — fixed in 3.5.14.0
- CODESYS Development System V3: from 3.0 before 3.5.14.0 — fixed in 3.5.14.0
- CODESYS Gateway Server V2: from 3.0 before 3.5.14.0 — fixed in 3.5.14.0
- CODESYS HMI (SL): from 3.0 before 3.5.14.0 — fixed in 3.5.14.0
- CODESYS Opc Server: from 3.0 before 3.5.14.0 — fixed in 3.5.14.0
- CODESYS PLCHandler: from 3.0 before 3.5.14.0 — fixed in 3.5.14.0
- CODESYS Safety SIL2: from 3.0 before 3.5.14.0 — fixed in 3.5.14.0
- CODESYS Targetvisu Sl: from 3.0 before 3.5.14.0 — fixed in 3.5.14.0
How to fix
Upgrade to a fixed version: CODESYS Control for BeagleBone SL 3.5.14.0; CODESYS Control For Empc-A/Imx6 Sl 3.5.14.0; CODESYS Control for IOT2000 SL 3.5.14.0; CODESYS Control for Linux SL 3.5.14.0; CODESYS Control for PFC100 SL 3.5.14.0; CODESYS Control for PFC200 SL 3.5.14.0; CODESYS Control for Raspberry Pi SL 3.5.14.0; CODESYS Control RTE (SL) 3.5.14.0; CODESYS Control Rte Sl (For Beckhoff Cx) 3.5.14.0; CODESYS Control Runtime Toolkit 3.5.14.0; CODESYS Control Win (SL) 3.5.14.0; CODESYS Development System V3 3.5.14.0. Check the vendor advisory for mitigations.
References
- http://www.securityfocus.com/bid/106251
- https://ics-cert.kaspersky.com/advisories/klcert-advisories/2018/12/19/klcert-18-036-codesys-control-v3-improper-communication-address-filtering/
- https://ics-cert.us-cert.gov/advisories/ICSA-18-352-04
- http://www.securityfocus.com/bid/106251
- https://ics-cert.kaspersky.com/advisories/klcert-advisories/2018/12/19/klcert-18-036-codesys-control-v3-improper-communication-address-filtering/
- https://ics-cert.us-cert.gov/advisories/ICSA-18-352-04
Get alerted when CVE-2018-20026 or the next vulnerability affects your stack