What’s Vulnerable › Vulnerabilities
CVE-2018-20092
- Severity: high (CVSS 7.5 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2018-12-17 · updated 2026-06-17
- Weakness: CWE-22
Description
PTC ThingWorx Platform through 8.3.0 is vulnerable to a directory traversal attack on ZIP files via a POST request.
Affected products
- PTC Thingworx Platform: from 7.0.0 through 7.0.14; before 7.0.0; from 7.1.0 through 7.1.18; from 7.2.0 through 7.2.21; from 7.3.0 through 7.3.18; from 7.4.0 through 7.4.14 — fixed in 7.0.0
How to fix
Upgrade to a fixed version: PTC Thingworx Platform 7.0.0. Check the vendor advisory for mitigations.
References
- https://www.doyler.net/security-not-included/ptc-thingworx-vulnerability
- https://www.ptc.com/en/documents/security/coordinated-vulnerability-disclosure/security-vulnerabilities
- https://www.doyler.net/security-not-included/ptc-thingworx-vulnerability
- https://www.ptc.com/en/documents/security/coordinated-vulnerability-disclosure/security-vulnerabilities
Get alerted when CVE-2018-20092 or the next vulnerability affects your stack