What’s Vulnerable › Vulnerabilities
CVE-2018-20105: yast2-rmt exposes CA private key passhrase in log-file
- Severity: medium (CVSS 5.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2020-01-27 · updated 2026-06-17
- Weakness: CWE-532
Description
A Inclusion of Sensitive Information in Log Files vulnerability in yast2-rmt of SUSE Linux Enterprise Server 15; openSUSE Leap allows local attackers to learn the password if they can access the log file. This issue affects: SUSE Linux Enterprise Server 15 yast2-rmt versions prior to 1.2.2. openSUSE Leap yast2-rmt versions prior to 1.2.2.
Affected products
- openSUSE Leap: 15.0
- SUSE Linux Enterprise: 15
- Yast2-Rmt Project Yast2-Rmt: before 1.2.2 — fixed in 1.2.2
How to fix
Upgrade to a fixed version: Yast2-Rmt Project Yast2-Rmt 1.2.2. Check the vendor advisory for mitigations.
References
- http://lists.opensuse.org/opensuse-security-announce/2020-02/msg00035.html
- http://lists.opensuse.org/opensuse-security-announce/2020-03/msg00015.html
- https://bugzilla.suse.com/show_bug.cgi?id=1119835
- http://lists.opensuse.org/opensuse-security-announce/2020-02/msg00035.html
- http://lists.opensuse.org/opensuse-security-announce/2020-03/msg00015.html
- https://bugzilla.suse.com/show_bug.cgi?id=1119835
Get alerted when CVE-2018-20105 or the next vulnerability affects your stack