What’s Vulnerable › Vulnerabilities
CVE-2018-20148
- Severity: critical (CVSS 9.8 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 26.8% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2018-12-14 · updated 2026-06-17
- Weakness: CWE-502
Description
In WordPress before 4.9.9 and 5.x before 5.0.1, contributors could conduct PHP object injection attacks via crafted metadata in a wp.getMediaItem XMLRPC call. This is caused by mishandling of serialized data at phar:// URLs in the wp_get_attachment_thumb_file function in wp-includes/post.php.
Affected products
- Debian Linux: 8.0, 9.0
- WordPress: before 4.9.9; from 5.0 before 5.0.1 — fixed in 4.9.9, 5.0.1
How to fix
Upgrade to a fixed version: WordPress 4.9.9, 5.0.1. Check the vendor advisory for mitigations.
References
- http://www.securityfocus.com/bid/106220
- https://blog.secarma.co.uk/labs/near-phar-dangerous-unserialization-wherever-you-are
- https://codex.wordpress.org/Version_4.9.9
- https://lists.debian.org/debian-lts-announce/2019/02/msg00019.html
- https://wordpress.org/news/2018/12/wordpress-5-0-1-security-release/
- https://wordpress.org/support/wordpress-version/version-5-0-1/
- https://wpvulndb.com/vulnerabilities/9171
- https://www.debian.org/security/2019/dsa-4401
- https://www.zdnet.com/article/wordpress-plugs-bug-that-led-to-google-indexing-some-user-passwords/
- https://www.zdnet.com/article/wordpress-vulnerability-affects-a-third-of-most-popular-websites-online/
- http://www.securityfocus.com/bid/106220
- https://blog.secarma.co.uk/labs/near-phar-dangerous-unserialization-wherever-you-are
Get alerted when CVE-2018-20148 or the next vulnerability affects your stack