What’s Vulnerable › Vulnerabilities
CVE-2018-20152
- Severity: medium (CVSS 6.5 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 3.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2018-12-14 · updated 2026-06-17
- Weakness: CWE-20
Description
In WordPress before 4.9.9 and 5.x before 5.0.1, authors could bypass intended restrictions on post types via crafted input.
Affected products
- Debian Linux: 8.0, 9.0
- WordPress: before 4.9.9; from 5.0 before 5.0.1 — fixed in 4.9.9, 5.0.1
How to fix
Upgrade to a fixed version: WordPress 4.9.9, 5.0.1. Check the vendor advisory for mitigations.
References
- http://www.securityfocus.com/bid/106220
- https://codex.wordpress.org/Version_4.9.9
- https://lists.debian.org/debian-lts-announce/2019/02/msg00019.html
- https://wordpress.org/news/2018/12/wordpress-5-0-1-security-release/
- https://wordpress.org/support/wordpress-version/version-5-0-1/
- https://wpvulndb.com/vulnerabilities/9170
- https://www.debian.org/security/2019/dsa-4401
- https://www.zdnet.com/article/wordpress-plugs-bug-that-led-to-google-indexing-some-user-passwords/
- http://www.securityfocus.com/bid/106220
- https://codex.wordpress.org/Version_4.9.9
- https://lists.debian.org/debian-lts-announce/2019/02/msg00019.html
- https://wordpress.org/news/2018/12/wordpress-5-0-1-security-release/
Get alerted when CVE-2018-20152 or the next vulnerability affects your stack