What’s Vulnerable › Vulnerabilities
CVE-2018-20162
- Severity: critical (CVSS 9.9 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 4.1% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2019-03-21 · updated 2026-06-17
- Weakness: CWE-20
Description
Digi TransPort LR54 4.4.0.26 and possible earlier devices have Improper Input Validation that allows users with 'super' CLI access privileges to bypass a restricted shell and execute arbitrary commands as root.
Affected products
- Digi Transport Lr54 Firmware: before 4.4.0.26 — fixed in 4.4.0.26
How to fix
Upgrade to a fixed version: Digi Transport Lr54 Firmware 4.4.0.26. Check the vendor advisory for mitigations.
References
- http://packetstormsecurity.com/files/151719/Digi-TransPort-LR54-Restricted-Shell-Escape.html
- https://blog.hackeriet.no/cve-2018-20162-digi-lr54-restricted-shell-escape/
- https://seclists.org/bugtraq/2019/Feb/34
- http://packetstormsecurity.com/files/151719/Digi-TransPort-LR54-Restricted-Shell-Escape.html
- https://blog.hackeriet.no/cve-2018-20162-digi-lr54-restricted-shell-escape/
- https://seclists.org/bugtraq/2019/Feb/34
Get alerted when CVE-2018-20162 or the next vulnerability affects your stack