What’s Vulnerable › Vulnerabilities
CVE-2018-20171
- Severity: medium (CVSS 6.1 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.6% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2018-12-17 · updated 2026-06-17
- Weakness: CWE-79
Description
An issue was discovered in Nagios XI before 5.5.8. The url parameter of rss_dashlet/magpierss/scripts/magpie_simple.php is not filtered, resulting in an XSS vulnerability.
Affected products
- Nagios XI: before 5.5.8 — fixed in 5.5.8
How to fix
Upgrade to a fixed version: Nagios XI 5.5.8. Check the vendor advisory for mitigations.
References
- https://www.nagios.com/downloads/nagios-xi/change-log/
- https://www.seebug.org/vuldb/ssvid-97713
- https://www.nagios.com/downloads/nagios-xi/change-log/
- https://www.seebug.org/vuldb/ssvid-97713
Get alerted when CVE-2018-20171 or the next vulnerability affects your stack