What’s Vulnerable › Vulnerabilities
CVE-2018-2021
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.9% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2019-07-17 · updated 2026-06-17
- Weakness: CWE-79
Description
IBM QRadar SIEM 7.2 and 7.3 is vulnerable to cross-site scripting. This vulnerability allows users to embed arbitrary JavaScript code in the Web UI thus altering the intended functionality potentially leading to credentials disclosure within a trusted session. IBM X-Force ID: 155345.
Affected products
- IBM QRadar SIEM: from 7.2.0 before 7.2.8; from 7.3.0 through 7.3.2; 7.2.8, 7.2.8-p1, 7.2.8-p10, 7.2.8-p11, 7.2.8-p12, 7.2.8-p13 (+10) — fixed in 7.2.8
How to fix
Upgrade to a fixed version: IBM QRadar SIEM 7.2.8. Check the vendor advisory for mitigations.
References
- https://exchange.xforce.ibmcloud.com/vulnerabilities/155345
- https://www.ibm.com/support/docview.wss?uid=ibm10888117
- https://exchange.xforce.ibmcloud.com/vulnerabilities/155345
- https://www.ibm.com/support/docview.wss?uid=ibm10888117
Get alerted when CVE-2018-2021 or the next vulnerability affects your stack