What’s Vulnerable › Vulnerabilities
CVE-2018-20217
- Severity: medium (CVSS 5.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2018-12-26 · updated 2026-06-17
- Weakness: CWE-617
Description
A Reachable Assertion issue was discovered in the KDC in MIT Kerberos 5 (aka krb5) before 1.17. If an attacker can obtain a krbtgt ticket using an older encryption type (single-DES, triple-DES, or RC4), the attacker can crash the KDC by making an S4U2Self request.
Affected products
- Debian Linux: 8.0, 9.0
- MIT Kerberos: before 5-1.17 — fixed in 5-1.17
How to fix
Upgrade to a fixed version: MIT Kerberos 5-1.17. Check the vendor advisory for mitigations.
References
- http://krbdev.mit.edu/rt/Ticket/Display.html?id=8763
- https://github.com/krb5/krb5/commit/5e6d1796106df8ba6bc1973ee0917c170d929086
- https://lists.debian.org/debian-lts-announce/2019/01/msg00020.html
- https://lists.debian.org/debian-lts-announce/2021/09/msg00019.html
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/2KNHELH4YHNT6H2ESJWX2UIDXLBNGB2O/
- https://security.netapp.com/advisory/ntap-20190416-0006/
- http://krbdev.mit.edu/rt/Ticket/Display.html?id=8763
- https://github.com/krb5/krb5/commit/5e6d1796106df8ba6bc1973ee0917c170d929086
- https://lists.debian.org/debian-lts-announce/2019/01/msg00020.html
- https://lists.debian.org/debian-lts-announce/2021/09/msg00019.html
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/2KNHELH4YHNT6H2ESJWX2UIDXLBNGB2O/
- https://security.netapp.com/advisory/ntap-20190416-0006/
Get alerted when CVE-2018-20217 or the next vulnerability affects your stack