What’s Vulnerable › Vulnerabilities
CVE-2018-20231
- Severity: high (CVSS 8.8 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.4% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2018-12-19 · updated 2026-06-17
- Weakness: CWE-352
Description
Cross Site Request Forgery (CSRF) in the two-factor-authentication plugin before 1.3.13 for WordPress allows remote attackers to disable 2FA via the tfa_enable_tfa parameter due to missing nonce validation.
Affected products
- Simbahosting Two-Factor-Authentication: before 1.3.13 — fixed in 1.3.13
How to fix
Upgrade to a fixed version: Simbahosting Two-Factor-Authentication 1.3.13. Check the vendor advisory for mitigations.
References
- https://wordpress.org/plugins/two-factor-authentication/#developers
- https://wpvulndb.com/vulnerabilities/9187
- https://www.privacy-wise.com/two-factor-authentication-cross-site-request-forgery-csrf-vulnerability-cve-2018-20231/
- https://wordpress.org/plugins/two-factor-authentication/#developers
- https://wpvulndb.com/vulnerabilities/9187
- https://www.privacy-wise.com/two-factor-authentication-cross-site-request-forgery-csrf-vulnerability-cve-2018-20231/
Get alerted when CVE-2018-20231 or the next vulnerability affects your stack