What’s Vulnerable › Vulnerabilities

CVE-2018-20239

Description

Application Links before version 5.0.11, from version 5.1.0 before 5.2.10, from version 5.3.0 before 5.3.6, from version 5.4.0 before 5.4.12, and from version 6.0.0 before 6.0.4 allows remote attackers to inject arbitrary HTML or JavaScript via a cross site scripting (XSS) vulnerability in the applinkStartingUrl parameter. The product is used as a plugin in various Atlassian products where the following are affected: Confluence before version 6.15.2, Crucible before version 4.7.0, Crowd before version 3.4.3, Fisheye before version 4.7.0, Jira before version 7.13.3 and 8.x before 8.1.0.

Affected products

How to fix

Upgrade to a fixed version: Atlassian Application Links 5.0.11, 5.2.10, 5.3.6, 5.4.12; Atlassian Confluence Data Center 6.15.2; Atlassian Confluence Data Center 6.15.2; Atlassian Crowd 3.4.3; Atlassian Crucible 4.7.0; Atlassian Fisheye 4.7.0; Atlassian Jira 7.13.3, 8.1.0; Atlassian Jira 7.13.3, 8.1.0. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2018-20239 or the next vulnerability affects your stack