What’s Vulnerable › Vulnerabilities
CVE-2018-20244
- Severity: medium (CVSS 5.5 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.0% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2019-02-27 · updated 2026-06-17
- Weakness: CWE-79
Description
In Apache Airflow before 1.10.2, a malicious admin user could edit the state of objects in the Airflow metadata database to execute arbitrary javascript on certain page views.
Affected products
- Apache Airflow: before 1.10.2 — fixed in 1.10.2
How to fix
Upgrade to a fixed version: Apache Airflow 1.10.2. Check the vendor advisory for mitigations.
References
- http://www.openwall.com/lists/oss-security/2019/04/10/6
- https://lists.apache.org/thread.html/2de387213d45bc626d27554a1bde7b8c67d08720901f82a50b6f4231%40%3Cdev.airflow.apache.org%3E
- https://lists.apache.org/thread.html/f656fddf9c49293b3ec450437c46709eb01a12d1645136b2f1b8573b%40%3Cdev.airflow.apache.org%3E
- http://www.openwall.com/lists/oss-security/2019/04/10/6
- https://lists.apache.org/thread.html/2de387213d45bc626d27554a1bde7b8c67d08720901f82a50b6f4231%40%3Cdev.airflow.apache.org%3E
- https://lists.apache.org/thread.html/f656fddf9c49293b3ec450437c46709eb01a12d1645136b2f1b8573b%40%3Cdev.airflow.apache.org%3E
Get alerted when CVE-2018-20244 or the next vulnerability affects your stack