What’s Vulnerable › Vulnerabilities
CVE-2018-20245
- Severity: high (CVSS 7.5 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.0% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2019-01-23 · updated 2026-06-17
- Weakness: CWE-295
Description
The LDAP auth backend (airflow.contrib.auth.backends.ldap_auth) prior to Apache Airflow 1.10.1 was misconfigured and contained improper checking of exceptions which disabled server certificate checking.
Affected products
- Apache Airflow: before 1.10.1 — fixed in 1.10.1
How to fix
Upgrade to a fixed version: Apache Airflow 1.10.1. Check the vendor advisory for mitigations.
References
- https://lists.apache.org/thread.html/b549c7573b342a6e457e5a3225c33054244343927bbfb2a4cdc4cf73%40%3Cdev.airflow.apache.org%3E
- https://lists.apache.org/thread.html/b549c7573b342a6e457e5a3225c33054244343927bbfb2a4cdc4cf73%40%3Cdev.airflow.apache.org%3E
Get alerted when CVE-2018-20245 or the next vulnerability affects your stack