What’s Vulnerable › Vulnerabilities
CVE-2018-20248
- Severity: critical (CVSS 9.8 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2018-12-24 · updated 2026-06-17
- Weakness: CWE-787
Description
In Foxit Quick PDF Library (all versions prior to 16.12), issue where loading a malformed or malicious PDF containing invalid xref table pointers or invalid xref table data using the LoadFromFile, LoadFromString, LoadFromStream, DAOpenFile or DAOpenFileReadOnly functions may result in an access violation caused by out of bounds memory access.
Affected products
- Foxit Quick PDF Library: before 16.12 — fixed in 16.12
How to fix
Upgrade to a fixed version: Foxit Quick PDF Library 16.12. Check the vendor advisory for mitigations.
References
- http://www.securityfocus.com/bid/106306
- https://www.foxitsoftware.com/support/security-bulletins.php
- http://www.securityfocus.com/bid/106306
- https://www.foxitsoftware.com/support/security-bulletins.php
Get alerted when CVE-2018-20248 or the next vulnerability affects your stack