What’s Vulnerable › Vulnerabilities
CVE-2018-20311
- Severity: high (CVSS 8.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.8% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-01-07 · updated 2026-06-17
- Weakness: CWE-125
Description
Foxit Reader before 9.5, and PhantomPDF before 8.3.10 and 9.x before 9.5, has a proxyCPDFAction race condition that can cause a stack-based buffer overflow or an out-of-bounds read.
Affected products
- Foxit PhantomPDF: before 8.3.10; from 9.0 before 9.5 — fixed in 8.3.10, 9.5
- Foxit Reader: before 9.5 — fixed in 9.5
How to fix
Upgrade to a fixed version: Foxit PhantomPDF 8.3.10, 9.5; Foxit Reader 9.5. Check the vendor advisory for mitigations.
References
- https://www.foxitsoftware.com/support/security-bulletins.php
- https://www.foxitsoftware.com/support/security-bulletins.php
Get alerted when CVE-2018-20311 or the next vulnerability affects your stack