What’s Vulnerable › Vulnerabilities
CVE-2018-20345
- Severity: medium (CVSS 5.3 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2018-12-21 · updated 2026-06-17
Description
Incorrect access control in StackStorm API (st2api) in StackStorm before 2.9.2 and 2.10.x before 2.10.1 allows an attacker (who has a StackStorm account and is authenticated against the StackStorm API) to retrieve datastore items for other users by utilizing the /v1/keys "?scope=all" and "?user=<username>" query filter parameters. Enterprise editions with RBAC enabled are not affected.
Affected products
- Stackstorm: before 2.9.2; from 2.10.0 before 2.10.1 — fixed in 2.10.1, 2.9.2
How to fix
Upgrade to a fixed version: Stackstorm 2.10.1, 2.9.2. Check the vendor advisory for mitigations.
References
- https://stackstorm.com/2018/12/20/stackstorm-v2-9-2-and-v2-10-1-a-security-release/
- https://stackstorm.com/2018/12/20/stackstorm-v2-9-2-and-v2-10-1-a-security-release/
Get alerted when CVE-2018-20345 or the next vulnerability affects your stack