What’s Vulnerable › Vulnerabilities
CVE-2018-20410
- Severity: high (CVSS 7.5 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.6% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2018-12-24 · updated 2026-06-17
- Weakness: CWE-787
Description
WellinTech KingSCADA before 3.7.0.0.1 contains a stack-based buffer overflow. The vulnerability is triggered when sending a specially crafted packet to the AlarmServer (AEserver.exe) service listening on TCP port 12401.
Affected products
- WellinTech KingSCADA: before 3.7.0.0.1 — fixed in 3.7.0.0.1
How to fix
Upgrade to a fixed version: WellinTech KingSCADA 3.7.0.0.1. Check the vendor advisory for mitigations.
References
- https://github.com/flypuma/vul/blob/master/kingview/copy_argumengt_overflow/Debugging.md
- https://github.com/flypuma/vul/blob/master/kingview/copy_argumengt_overflow/poc.py
- https://github.com/flypuma/vul/blob/master/kingview/copy_argumengt_overflow/Debugging.md
- https://github.com/flypuma/vul/blob/master/kingview/copy_argumengt_overflow/poc.py
Get alerted when CVE-2018-20410 or the next vulnerability affects your stack