What’s Vulnerable › Vulnerabilities
CVE-2018-20455
- Severity: medium (CVSS 5.5 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.1% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2018-12-25 · updated 2026-06-17
- Weakness: CWE-787
Description
In radare2 prior to 3.1.1, the parseOperand function inside libr/asm/p/asm_x86_nz.c may allow attackers to cause a denial of service (application crash via a stack-based buffer overflow) by crafting an input file, a related issue to CVE-2018-20456.
Affected products
- radareorg/radare2: before 3.1.1 — fixed in 3.1.1
How to fix
Upgrade to a fixed version: radareorg/radare2 3.1.1. Check the vendor advisory for mitigations.
References
- https://github.com/radare/radare2/commit/9b46d38dd3c4de6048a488b655c7319f845af185
- https://github.com/radare/radare2/issues/12373
- https://github.com/radare/radare2/commit/9b46d38dd3c4de6048a488b655c7319f845af185
- https://github.com/radare/radare2/issues/12373
Get alerted when CVE-2018-20455 or the next vulnerability affects your stack