What’s Vulnerable › Vulnerabilities
CVE-2018-20458
- Severity: medium (CVSS 5.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.9% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2018-12-25 · updated 2026-06-17
- Weakness: CWE-125
Description
In radare2 prior to 3.1.1, r_bin_dyldcache_extract in libr/bin/format/mach0/dyldcache.c may allow attackers to cause a denial-of-service (application crash caused by out-of-bounds read) by crafting an input file.
Affected products
- radareorg/radare2: before 3.1.1 — fixed in 3.1.1
How to fix
Upgrade to a fixed version: radareorg/radare2 3.1.1. Check the vendor advisory for mitigations.
References
- https://github.com/radare/radare2/issues/12374
- https://github.com/radareorg/radare2/commit/30f4c7b52a4e2dc0d0b1bae487d90f5437c69d19
- https://github.com/radare/radare2/issues/12374
- https://github.com/radareorg/radare2/commit/30f4c7b52a4e2dc0d0b1bae487d90f5437c69d19
Get alerted when CVE-2018-20458 or the next vulnerability affects your stack