What’s Vulnerable › Vulnerabilities
CVE-2018-20460
- Severity: medium (CVSS 5.5 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.1% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2018-12-25 · updated 2026-06-17
- Weakness: CWE-787
Description
In radare2 prior to 3.1.2, the parseOperands function in libr/asm/arch/arm/armass64.c allows attackers to cause a denial-of-service (application crash caused by stack-based buffer overflow) by crafting an input file.
Affected products
- radareorg/radare2: before 3.1.2 — fixed in 3.1.2
How to fix
Upgrade to a fixed version: radareorg/radare2 3.1.2. Check the vendor advisory for mitigations.
References
- https://github.com/radare/radare2/commit/df167c7db545953bb7f71c72e98e7a3ca0c793bf
- https://github.com/radare/radare2/issues/12376
- https://github.com/radare/radare2/commit/df167c7db545953bb7f71c72e98e7a3ca0c793bf
- https://github.com/radare/radare2/issues/12376
Get alerted when CVE-2018-20460 or the next vulnerability affects your stack