What’s Vulnerable › Vulnerabilities
CVE-2018-20494
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.6% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2019-12-30 · updated 2026-06-17
- Weakness: CWE-863
Description
An issue was discovered in GitLab Community and Enterprise Edition before 11.4.13, 11.5.x before 11.5.6, and 11.6.x before 11.6.1. It has Incorrect Access Control.
Affected products
- GitLab: from 8.4.0 before 11.4.13; from 11.5.0 before 11.5.6; from 11.6.0 before 11.6.1 — fixed in 11.4.13, 11.5.6, 11.6.1
How to fix
Upgrade to a fixed version: GitLab 11.4.13, 11.5.6, 11.6.1. Check the vendor advisory for mitigations.
References
- https://about.gitlab.com/2018/12/31/security-release-gitlab-11-dot-6-dot-1-released/
- https://gitlab.com/gitlab-org/gitlab-ce/issues/54334
- https://about.gitlab.com/2018/12/31/security-release-gitlab-11-dot-6-dot-1-released/
- https://gitlab.com/gitlab-org/gitlab-ce/issues/54334
Get alerted when CVE-2018-20494 or the next vulnerability affects your stack