What’s Vulnerable › Vulnerabilities
CVE-2018-20669
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2019-03-21 · updated 2026-06-17
- Weakness: CWE-20
Description
An issue where a provided address with access_ok() is not checked was discovered in i915_gem_execbuffer2_ioctl in drivers/gpu/drm/i915/i915_gem_execbuffer.c in the Linux kernel through 4.19.13. A local attacker can craft a malicious IOCTL function call to overwrite arbitrary kernel memory, resulting in a Denial of Service or privilege escalation.
Affected products
- Canonical Ubuntu Linux: 14.04, 16.04, 18.04
- Linux kernel: from 4.13 before 4.14.185; from 4.15 before 4.19.129; from 4.20 before 5.0 — fixed in 4.14.185, 4.19.129, 5.0
- NetApp Cn1610 Firmware: all versions
- NetApp Hci Management Node: all versions
- NetApp Snapprotect: all versions
- NetApp Solidfire: all versions
How to fix
Upgrade to a fixed version: Linux kernel 4.14.185, 4.19.129, 5.0. Check the vendor advisory for mitigations.
References
- http://git.kernel.org/cgit/linux/kernel/git/torvalds/linux.git/log/drivers/gpu/drm/i915/i915_gem_execbuffer.c
- http://lists.opensuse.org/opensuse-security-announce/2019-02/msg00042.html
- http://www.openwall.com/lists/oss-security/2019/01/23/6
- http://www.securityfocus.com/bid/106748
- https://access.redhat.com/security/cve/cve-2018-20669
- https://security.netapp.com/advisory/ntap-20190404-0002/
- https://support.f5.com/csp/article/K32059550
- https://usn.ubuntu.com/4485-1/
- http://git.kernel.org/cgit/linux/kernel/git/torvalds/linux.git/log/drivers/gpu/drm/i915/i915_gem_execbuffer.c
- http://lists.opensuse.org/opensuse-security-announce/2019-02/msg00042.html
- http://www.openwall.com/lists/oss-security/2019/01/23/6
- http://www.securityfocus.com/bid/106748
Get alerted when CVE-2018-20669 or the next vulnerability affects your stack