What’s Vulnerable › Vulnerabilities
CVE-2018-20676
- Severity: medium (CVSS 6.1 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 3.8% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2019-01-09 · updated 2026-06-17
- Weakness: CWE-79
Description
In Bootstrap before 3.4.0, XSS is possible in the tooltip data-viewport attribute.
Affected products
- Getbootstrap Bootstrap: before 3.4.0 — fixed in 3.4.0
How to fix
Upgrade to a fixed version: Getbootstrap Bootstrap 3.4.0. Check the vendor advisory for mitigations.
References
- https://access.redhat.com/errata/RHBA-2019:1076
- https://access.redhat.com/errata/RHBA-2019:1570
- https://access.redhat.com/errata/RHSA-2019:1456
- https://access.redhat.com/errata/RHSA-2019:3023
- https://access.redhat.com/errata/RHSA-2020:0132
- https://access.redhat.com/errata/RHSA-2020:0133
- https://blog.getbootstrap.com/2018/12/13/bootstrap-3-4-0/
- https://github.com/twbs/bootstrap/issues/27044
- https://github.com/twbs/bootstrap/issues/27915#issuecomment-452140906
- https://github.com/twbs/bootstrap/issues/27915#issuecomment-452196628
- https://github.com/twbs/bootstrap/pull/27047
- https://lists.apache.org/thread.html/rd0e44e8ef71eeaaa3cf3d1b8b41eb25894372e2995ec908ce7624d26%40%3Ccommits.pulsar.apache.org%3E
Get alerted when CVE-2018-20676 or the next vulnerability affects your stack