What’s Vulnerable › Vulnerabilities
CVE-2018-20683
- Severity: high (CVSS 8.1 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.0% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2019-01-10 · updated 2026-06-17
- Weakness: CWE-20
Description
commands/rsync in Gitolite before 3.6.11, if .gitolite.rc enables rsync, mishandles the rsync command line, which allows attackers to have a "bad" impact by triggering use of an option other than -v, -n, -q, or -P.
Affected products
- Gitolite: before 3.6.11 — fixed in 3.6.11
How to fix
Upgrade to a fixed version: Gitolite 3.6.11. Check the vendor advisory for mitigations.
References
- https://bugs.debian.org/918849
- https://github.com/sitaramc/gitolite/blob/master/CHANGELOG
- https://github.com/sitaramc/gitolite/commit/5df2b817255ee919991da6c310239e08c8fcc1ae
- https://groups.google.com/forum/#%21topic/gitolite-announce/6xbjjmpLePQ
- https://bugs.debian.org/918849
- https://github.com/sitaramc/gitolite/blob/master/CHANGELOG
- https://github.com/sitaramc/gitolite/commit/5df2b817255ee919991da6c310239e08c8fcc1ae
- https://groups.google.com/forum/#%21topic/gitolite-announce/6xbjjmpLePQ
Get alerted when CVE-2018-20683 or the next vulnerability affects your stack