What’s Vulnerable › Vulnerabilities
CVE-2018-20699
- Severity: medium (CVSS 4.9 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2019-01-12 · updated 2026-06-17
- Weakness: CWE-400
Description
Docker Engine before 18.09 allows attackers to cause a denial of service (dockerd memory consumption) via a large integer in a --cpuset-mems or --cpuset-cpus value, related to daemon/daemon_unix.go, pkg/parsers/parsers.go, and pkg/sysinfo/sysinfo.go.
Affected products
- Docker Engine: before 18.09 — fixed in 18.09
- RedHat Enterprise Linux Server: 7.0
How to fix
Upgrade to a fixed version: Docker Engine 18.09. Check the vendor advisory for mitigations.
References
- https://access.redhat.com/errata/RHSA-2019:0487
- https://github.com/docker/engine/pull/70
- https://github.com/moby/moby/pull/37967
- https://access.redhat.com/errata/RHSA-2019:0487
- https://github.com/docker/engine/pull/70
- https://github.com/moby/moby/pull/37967
Get alerted when CVE-2018-20699 or the next vulnerability affects your stack