What’s Vulnerable › Vulnerabilities
CVE-2018-20714
- Severity: high (CVSS 8.1 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.8% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2019-01-15 · updated 2026-06-17
- Weakness: CWE-22
Description
The logging system of the Automattic WooCommerce plugin before 3.4.6 for WordPress is vulnerable to a File Deletion vulnerability. This allows deletion of woocommerce.php, which leads to certain privilege checks not being in place, and therefore a shop manager can escalate privileges to admin.
Affected products
- Automattic WooCommerce: before 3.4.6 — fixed in 3.4.6
How to fix
Upgrade to a fixed version: Automattic WooCommerce 3.4.6. Check the vendor advisory for mitigations.
References
- https://blog.ripstech.com/2018/wordpress-design-flaw-leads-to-woocommerce-rce/
- https://blog.ripstech.com/2018/wordpress-design-flaw-leads-to-woocommerce-rce/
Get alerted when CVE-2018-20714 or the next vulnerability affects your stack